Legacy Email Activity Feed: Twilio SendGrid Reseller Partners & Email API Premier plans above 50m*

Issue

Twilio SendGrid Reseller Partners and Premier accounts above 50m will only have access to a Legacy Email Activity Feed which will include the most recent 500 events or the past 7 days of activities.

Twilio SendGrid Reseller Partners and Premier accounts above 50m do not have access to the same Email Activity Feed as native Twilio SendGrid accounts (Premier Plans 50M and below). Specifically, these accounts cannot export data from the Email Activity Feed or utilize the 30-day Email Activity History Feed.

 

Product

Twilio SendGrid Reseller Partners & Premier accounts above 50m.

 

Cause

Twilio SendGrid Reseller Partners and Premier accounts above 50m accounts will only have access to the legacy Activity Feed. Customers will be able to see details of each event by hovering over the Screen_Shot_2022-06-23_at_11.57.13_AM.png icon on the right side of the event. Depending on the event, different filters and information will be provided.

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Below is a break down of what each filter represents in relation to the Event.

Email activity feed filter details (for Twilio SendGrid Reseller Partner accounts):

Email

To/Recipient Email Address

Reason

The response message from the recipient email server

SMTP-ID

A unique ID attached to the message by the originating system

Processed String

The time when the event occurred (Relative to the timezone set in the account)

MSGID

A unique, internal Twilio SendGrid ID for the message

Client IP

The IP address Twilio SendGrid received the email request from the originating system

URL

The URL the Click event tracked (Requires Click Tracking to be enabled)

 

Resolution

The workaround is to set up Event Webhook to capture client-side data. Customers can gain access to all email activity associated with their account in real-time by integrating Event Webhook, which is already included in their plan.

SendGrid’s Event Webhook will notify a URL of your choice via HTTP POST with information about events that occur while SendGrid is processing your email. Common uses for this data include removing unsubscribes, responding to spam reports, determining unengaged recipients, identifying bounced email addresses, or creating advanced analytics for your email program

 

Additional information 

It is important to note that this functionality will only start storing the events related to your account when it becomes integrated into your SendGrid account. This will not track any of the events that occurred before the Event Webhook was integrated. The number of Event Webhook that can be set up depends on the plan:

  • Premier plans above 50m support up to 5 webhooks** per parent/each subuser
  • Resellers support 1 webhook*** per parent/each subuser.

**5 is a hard limit.
***These accounts will not get multiple Event Webhooks. This only applies to direct SendGrid accounts.

Twilio SendGrid Event Webhook Overview

Event Webhook Reference

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