Unable to Upload Contacts via a CSV file

Issue

When uploading CSV files to add contacts to your Marketing plan, you may experience an error or partial upload of contacts. We will send a confirmation of contact uploads to the admin email address on file as well as any email addresses that are included within the "Marketing" > "Notifications" menu. You can add up to 10 additional addresses per account.

The email will contain the following information:

  • Uploaded (total number of unique contacts read in the CSV file)
  • New (number of new contacts that did not previously exist in any list on your account)
  • Updated (number of contacts that already existed on the account but were updated)
  • Errors (number of contacts that failed to upload due to an error)

Product

Twilio SendGrid Email Marketing Campaigns.

Cause

When errors are logged in an upload, that email will include a blue button under this information:  

"Download Detailed Error File". This file will include the email addresses and error reasons.

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The most common issue we see with uploading contacts via CSV (Comma Separated Values) file is an error with the content of the file. We frequently see values in files separated by a semicolon ; - rather than the correct comma ,.

Even in files with proper formatting (CSV), the software used to create the file or different regional/language options, could produce a file with values separated by semicolons.

If your CSV file doesn't upload as anticipated, we recommend checking the file in a text editor to make sure it's not using semicolons for separating values. 

  1. Open with your preferred text editor.
  2. Use the Find and Replace option to search for ;.
  3. Replace all semicolons with ,.
  4. Save the file as a .csv.

Another common issue happens when your CSV does not contain the following information about each contact:

email
phone_number_id
external_id
anonymous_id
first_name
last_name

Only one of email, phone_number_id, external_id, or anonymous_id is required. 

This error "primary_identifiers, a contact matching the given identifiers also contains other identifiers. Please provide all identifiers to update the record. Alternatively you could remove the other identifiers using Delete Identifier API" is also very common when there are contacts on the account that already use some identifiers you are including in the upload. 

Resolution

To avoid formatting issues you will need to follow the rules outlined in this document Formatting a CSV to upload your contacts into Marketing Campaigns.

Regarding the "primary_identifiers" error message in order to upload/update contacts details you need to include all of the other identifiers that are already included on the account for those contacts. For example:

if you upload a contact with the identifiers:
email
phone_number_id
anonymous_id
when I upload it again to update information, if you try to upload with only
email
anonymous_id
You would get the error since phone_number_id is not included in your upload.

If you are not able to supply all identifiers you can use this endpoint to delete identifiers and update your contacts.

Additional Information 

Please check these documents for additional details:

Create and Manage Contacts

Using Custom Fields

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