Issue
Customers should receive a bounce email if our system records a bounce event. Sometimes, the customer doesn't get these emails as expected, despite our tools and the SendGrid UI showing there was a bounce event.
Product
Twilio SendGrid
Cause
The Forward Bounce Messages option is enabled
Resolution
In KASI, information about Bounce settings appears on the right-hand side.
In MySQL, information about Bounce settings can be found under the Mail Settings DB > bounce_management table.
If you use the first option (Use the From address of the outgoing email): the email will go to the Return_Path email address.
KASI will appear like this:
MySQL will appear like this:
If you use the second option (Specify email address), the bounce will go to the specified email address. KASI will appear like this:
and MySQL will appear like this:
However, if you use the second option (Specify email address), without actually entering an email address, the setting will be accepted. The option "Use the From address of the outgoing email" will be automatically selected.
Solution 1:
Ask the customer to disable "Forward Bounce Messages".
Solution 2:
If the first option was selected, ask the customer to select the second option instead and enter a valid email address there.
Solution 3:
If the second option is selected, and there is a valid email address entered there, ask the customer to contact the email administrators of the email address entered, so they can determine where the bounce email went.
Solution 4:
If you see a Forward Address = None in KASI, ask the customer to enter a forwarding email address, or disable "Forward Bounce Messages".
Additional information
1. A Forward Address: None in KASI means that the change was made by a TSE directly in KASI.
2. When troubleshooting Forward Bounce issues, please keep in mind that those emails are sent from no-reply@sendgrid.net
3. Delayed Bounces might be more difficult to observe in KASI, because there is less contextual detail that can be tied to the event when asynchronous bounces take place. On consequence, data like message_id and IP might be lost. You might need to look for those bounces using the following:
app: bouncely
mail_from: no-reply@sendgrid.net
event: forward
rcpt_to: [forwarding_email_address]