"403 Access Forbidden" error when accessing the Email Activity API

 

Issue

Attempts to get Email Activity via API using the endpoint https://api.sendgrid.com/v3/messages results in a "403 Access Forbidden" error. 

 

Product

Twilio SendGrid - Email API

 

Cause

There are two possible causes for the issue:

1. You have not purchased the 30 Days Additional Email Activity History Add-On

2. Your API key doesn't have the required permissions

 

Resolution

If you have not purchased the 30 Days Additional Email Activity History Add-On

If you created your account directly through sendgrid.com or twilio.com, you can purchase the Add-On by following these steps:

1. Go to Settings > Account Details

2. Go to "Your Products"

3. Click the "Add to Plan" button in the "Extended Email Activity History" Add-On

Note: You need to be the primary administrator of the account, or a Teammate with Administration permissions to complete the purchase

 

If you already purchased the 30 Days Additional Email Activity History Add-On

You need to generate a new API Key with Email Activity permissions or edit an existing API Key to include this permission:

 

If you already purchased the Add-On and generated an API Key with the required permissions

It might be a matter of propagation. It takes a while for the billing update to propagate to the SendGrid system, and some time more for our system to prepare all the data related to the Email Activity for the last 30 days. Please wait 12 hours after the Add-On purchase to start using the API.

 

Additional information 

  • For more information on how to use the Email Activity API, you can refer to this support article. 
  • Accounts purchased through one of our Resellers (Azure, GCP, Heroku, KKE) cannot purchase this Add-On. The alternative for these accounts is setting up an Event Webhook instead. 
  • If you continue to experience issues after following these steps, consider reaching out to Twilio SendGrid Support for further assistance.
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