Issue
When adding CNAME records to the GoDaddy domain host DNS records, they typically will automatically append the domain name to the record automatically.
Product
Email
Cause
For example, if a record like this is added:
em1234.domain.com
It actually is added like this:
em1234.domain.com.domain.com
Resolution
To resolve this issue, edit the CNAME record to remove the .domain.com
portion of the record, or remove, and create the records again without the .domain.com
portion of the record.
Record Type | Record Name | Record Value |
---|---|---|
CNAME | em1234 | u1234567.wl123.sendgrid.net |
CNAME | s1._domainkey | s1.domainkey.u1234567.wl123.sendgrid.net |
CNAME | s2._domainkey | s2.domainkey.u1234567.wl123.sendgrid.net |
After updating DNS records, please allow up to 24-48 hours for the records to propagate and show as Verified in SendGrid. If you've waited that time period, and they still are not propagating, please don't hesitate to reach out to Support via the Support Portal.
Notice: If you have multiple Domain Authentication entries for the same domain in your SendGrid account (Settings > Sender Authentication), make sure to remove all the ones that are Pending or Failed and leave only the one(s) that state Verified.