Invited password teammate gets created as SSO teammate

Issue

When attempting to add a password teammate to a Twilio SendGrid account, the teammate is unexpectedly created as a Single Sign-On (SSO) teammate. This can cause confusion and access issues, as the intended login method and permissions may not align with the organization's requirements.

 

Product

Twilio SendGrid (Email)

 

Cause

Session cookies from other accounts (Twilio Legacy, SendGrid legacy or Unified Twilio accounts) being present in the Teammate's browser when accepting the invitation. 

 

Resolution

There are several alternatives to prevent the creation of a password teammate as SSO one:

  • Accept the email invitation on a completely different machine than the invitation was sent on.
  • If the teammate must accept the invitation on the same browser/machine used to send the invitation: Send the invitation, manually log out, and then open a new browser, navigate to the email invite, and click “Accept Invitation”. 
  • Double check that the email address they sent the invitation to is the exact same email address (case sensitivity included) that was invited. 
  • If none of the above resolve the issue, please try this:
  • Ask the teammate to delete cache and cookies on their browser once more, navigate to sendgrid.com/login and enter their username there. If our system detects that they are a unified teammate, they will then be directed to a Twilio branded login page where they can enter the email address/password they signed up with. They should then be directed to the SendGrid dashboard if the credentials were properly created. If they do not remember their password, they can always reset it on the same page. 

Additional Information 

  • Teammate Invitations: Invitations are valid for 7 days. Ensure the teammate accepts the invitation within this timeframe.
  • SSO Configuration: If your organization uses SSO, ensure that it is correctly configured to prevent automatic conversion of password teammates to SSO.
  • Support Resources: If none of our suggestions worked for the teammate, please ask them to record a video showing the login process, and reach out to us at https://support.sendgrid.com including the link to the video or attaching it. 
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