Unable to subscribe to SendGrid via GCP

Issue

When trying to subscribe to SendGrid you might encounter two errors:

Unable to proceed as this is a reseller partner billing account

There is already an order associated with this billing account

These errors might happen even if there is no existing SendGrid subscription displayed under Marketplace > Your Products 

 

Product

Twilio SendGrid (Email API and Marketing Campaigns)

 

Cause

Unable to proceed as this is a reseller partner billing account

The Marketing Campaigns plan uses the same billing account as the Email API plan. 

 

There is already an order associated with this billing account

There was an error during the initial subscription process or a previous subscription was cancelled. In either case, a subscription ID, linked to the current billing account, already exists. Our system only allows one entitlement per billing account, and even a cancelled entitlement counts as an association. In turn, the reason for this behavior, is that iSaaS products on the GCP marketplace are tied to Billing account, not to specific projects. 

 

Resolution

Unable to proceed as this is a reseller partner billing account

You need to subscribe to an Email API Plan before being able to add Marketing Campaigns through GCP. 

There is already an order associated with this billing account

Subscribe again using a different billing account. 

 

Additional Information 

You can check the status of your orders in GCP by going to https://console.cloud.google.com/marketplace/orders and selecting your Billing account. For more information, please refer to Managing billing for Cloud Marketplace products

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