Issue
SendGrid customers can eventually hit their template limit and will be prompted to an error saying "You reached your template limit, please contact support".
The goal of this article to help users to know what to do for these cases and what to do if this happens.
Product
Twilio SendGrid (Email API)
Cause
The maximum number of transactional templates and versions per user ID is limited to 300. This means you can have 300 templates with 1 version each, or fewer templates with more versions of each template. This is a soft limit that can be increased.
Resolution
The only way to increase the template limit (including available versions) is to contact SendGrid Support, but please take into account the following recommended guidelines to increase this limit:
- Whilst limit can be increased, it can be done by a few hundreds. We won't be able to double the limit in the first interaction
- The maximum recommended limit for templates is 1000, beyond this limit it has to be approved by the senior team. It has been confirmed that beyond the 1000 limit, there could be some downgraded performance on the SendGrid UI that can affect multiple functionalities (saving errors, duplicated savings, name mismatches, and long loading screens)
To ensure optimal performance, we won't be increasing template limits beyond 1000 unless there's a justifiable reason behind it. This will be reviewed by our Senior Support.
Note that it is customer's responsibility to keep a healthy amount of used templates, so before submitting any new template limit increase request, please make sure to delete any old and unused templates.
We'll be more than glad to increase the limit for you!
Additional Information
For more information on templates, please visit:
Create and Edit Legacy Transactional Templates
How to Send an Email with Dynamic Templates