Delivery issues to Microsoft-related email address

 

Issue

Most emails sent via SendGrid to free Microsoft accounts are being blocked and not delivered. The error message received might look like:
550 5.7.1 ... Please contact your Internet service provider since part of their network is on our block list (S3140).

 

Product

Twilio SendGrid (Email API and/or Marketing Campaigns)

 

Cause

If your account is Free or under a plan that uses shared IPs

Shared IPs can be blocklisted by email providers like Microsoft due to the collective sending behavior of all users sharing the IP. This is particularly common in shared IP pools with lower reputations.

If your account is under a plan that already uses dedicated IPs

Incorrect sending behavior has impacted the reputation of your sending IP. 

 

Resolution

If your account uses Shared IPs

  1. Increase Sending Volume: If you send less than 1000 emails per month, try to increase your email sending volume, so our system can determine your Engagement Quality Score and move your account to a different IP group within our shared infrastructure.
  2. Enable Open tracking: Even if you send a high volume of emails through shared IPs, without Open tracking our system won't be able to assess your Engagement Quality Score.
  3. Track your Engagement Quality Scores: Our system groups senders by engagement quality. The better your sending practices, the higher your score will be and therefore, you will be grouped with better senders, thus reducing the chances for blocks by several RBLs, Microsoft or other email providers.
  4. Consider a Dedicated IP: Upgrading to a plan with a dedicated IP can reduce the chances of being blocklisted, as you will be the sole user responsible for its reputation. However, ensure you have a sufficient sending volume to justify the cost.

If your account uses dedicated IPs

  1. Make sure to follow Microsoft's Guidelines
  2. You can also check your Engagement Quality Scores to improve your sending behavior.
  3. Subscribe to SNDS (Smart Network Data Services) to track the reputation of your dedicated IPs
  4. Contact Outlook.com Deliverability Support so they can provide additional insights

 

Additional Information 

Information on how to improve the different SEQ scores is available in this Support article

To learn more about our prices, you can refer to:

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