Issue
Emails are being automatically dropped, despite the recipients not being in any suppression list. The Drop reason shows "Invalid Template".
Product
Twilio SendGrid (Email API)
Cause
The Template ID doesn't exist or is not active
Resolution
- Verify that the Template ID on your payload corresponds to an existing Dynamic Template ID
- Make sure that the Template ID version you are entering in the payload is active. For that purpose, make sure to click the "Make Active" option for the correct version, as follows:

Note: To activate a template via API, you can follow the steps at https://www.twilio.com/docs/sendgrid/api-reference/transactional-templates-versions/activate-a-transactional-template-version
Additional Information
To check the Drop reason, click the email address in the Email Activity Feed results, so you can expand all the related information, and then, click the arrow to the right of Dropped.