Issue
A SPF=fail evaluation starts appearing in email headers after adding a new IP to an account (parent or subuser), leading to Spam classification or email delivery issues.
Product
Twilio SendGrid (Email API and/or Marketing Campaigns)
Cause
The new IP has not been added to the SPF record related to the domain authentication.
Resolution
If you used "Automated Security" during the Domain Authentication process
Look for the related domain authentication under Settings > Sender Authentication, click it and then click again the "Verify" button. Although our system is designed to automatically update the SPF, it doesn't happen right after adding a new dedicated IP. Clicking the "Verify" button will prompt our system to update the record right away.
If you didn't use "Automated Security" during the Domain Authentication process
On the DNS host of your domain, look for the TXT records used for SPF purposes and manually add the new IP, with the ip4 prefix. For example, if it was originally:
v=spf1 ip4:149.72.182.77 -all and you add the IP 159.103.10.26, the resulting SPF record should be:
v=spf1 ip4:149.72.182.77 ip4:159.103.10.26 -all
If instead you changed the IP ip4:149.72.182.77 by the IP 159.103.10.26, the resulting SPF record should be:
v=spf1 ip4:159.103.10.26 -all