Apple Devices not Triggering sg_machine_open

Issue

The sg_machine_open field is a boolean (true/false) indicator of whether or not an open event has been generated by Apple Mail Privacy Protection (MPP). The true value indicates SendGrid has received signals indicating that a recipient with MPP enabled has triggered an open event, while false indicates that the event was triggered by a conventional (non-MPP) open. 

Product

Email

Cause

There may be cases where the field sg_machine_open is not registering "True" and this might be happening for all the open events. Maybe it is working correctly or maybe there is something failing. In order to check if it's working correctly you might perform the next troubleshooting steps. 

 

Resolution 

Check if sg_machine_open is working correctly: 

Prerequisites

Process

  1. Once you have configured your email account, and mail privacy protection is enabled, please send a test email through your SendGrid account.
  2. Access the Mail app , and then open the test email that you sent.
    Note: DO NOT open the email using a VPN. If using a VPN, you'll need to first disconnect from it, and then open the email. Ideally, try to open the email while connected to your Wi-Fi network or a hotspot.
  3. Review the open event in your Twilio SendGrid Email webhook, and confirm you are seeing the field sg_machine_open=True.

Troubleshooting

  • If the account has SSL configured in SendGrid, a proxy server is being used. In this case, the proxy server is not passing the original IP that opened the email. Note that SendGrid relies on the proxy servers to provide the originating IP. If the proxy server does not put the originating IP address into theX-Forwarded-For header, there’s no way for SendGrid to know the open is originated from an apple server. Please contact your proxy/CDN provider and look for assistance to fix this. 
  • If the account is using standard click tracking and has Link Branding configured, but the sg_machine_open is not accurately reported as "true", there may be an issue with the Link Branding configuration that is stopping opens and clicks from being accurately tracked and reported. Please review the documentation for setting up Link Branding and ensure that your link branding records are correctly configured in your DNS provider: How to set up Link Branding
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