Resolving the 400 Error 'Cannot schedule in the past' in Single Sends

Issue

The error 'Unable to send your Single Send' appears in the SendGrid dashboard, despite testing emails being successfully delivered. 

 

Product

Twilio SendGrid (Email)

 

Cause

Checking the Developer Tools (in Chrome) or the Web Inspector (in Safari) shows a 400 error with the following response even when 'Send Immediately' is selected.

Schedule() on the client failed: {"errors":[{"field":"send_at","message":"cannot schedule in the past"}]}

 

Resolution

Please follow these troubleshooting steps:

  1. Sign in to your SendGrid account using a private/incognito window. If this resolves the issue, deleting cache and cookies on your browser will prevent the issue from happening again. 
  2. Clone the template and try to send the clone. 
  3. Use a different browser. If this resolves the issue, deleting cache and cookies on your usual browser will prevent the issue from happening again. 
  4. Try triggering the Single Send from a different device. If this resolves the issue, please ensure that your browser is up-to-date and that the system settings on your device are correct. 

 

Additional Information 

The 'send at' parameter used to schedule a Single Send aligns with the timestamp in our servers, which is why if your browser is not up-to-date or there is a system issue on your device, the hour you have might predate the one on our side, leading to the error described above. 

 

For more information you can refer to Single Sends scheduling.

Have more questions? Submit a request