Issue
If you're experiencing issues with your Automation, and it is failing to go live or is being timed out or failing the scheduling this is the guide for you.
Product
Twilio SendGrid Email
Cause
Sometimes, automation's size can impact your configuration.
Resolution
Please split the existing emails in 2 automations series instead of just one. You can follow the steps below:
- Duplicate the Automation/series
- In the original Automation delete the emails in the second half of the series
- In the duplicate series, delete the emails in the first half of the series, or up to the number they left remaining in the original
- Create a new segment of the List/Segment that triggers the original Automation based on Automation Activity, i.e. Automation Activity WAS SENT {Automation Name} - All Email # (where Email # is the last email in the original series) within the last X Days, (X should be the interval that you would have set were you will be able to keep all of the emails in one series)
- Associate the duplicate series with the segment created in step 4
- Give both series names that describe how they work together, i.e. My automation - All - 1/2 and My automation - All - 2/2
- Set both series live
- Add contacts to the first segment which will begin triggering the first Automation series
Additional information
If you need any further help, also check our guide on how to Duplicate an Automation in case the automation itself fails. You may want to try to duplicate it to try again.