Troubleshooting for Automations not Triggering

Issue

This article helps outline troubleshooting steps when your automation is not triggering to your contact list.

Product

Email 

Cause

Our automation feature for New Marketing Campaigns is a great resource for drip campaigns, welcome sequences, or even a regularly occurring set of campaigns that go together. A regular question our support team sees is, “Why isn’t my live automation sending to the contacts in the assigned list?”. In this case, the resolution can be broken down into a few steps to make sure that automation sends it out properly.

 

Resolution

Disable the automation

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Within your live automation, navigate to the automation options dropdown and select disable automation. This step will not delete all the work you spent creating your automation, but will allow you to make necessary edits and changes to your automation. You will be able to set it back to live at any point, which we will be doing later in step 6.

Export the List’s CSV

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Within your contact list, navigate to the list that is tied to the automation and in the right hand corner, select export CSV. This step is to ensure that the membership of your list stays the same as it would have been otherwise. Exporting your lists is also a helpful best practice in general for keeping logs of your contacts outside of your SendGrid account.

 

Delete your List

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Within that same contact list tied to your automation and that we triggered the CSV export for, select the delete this list button right next to the export CSV option. You will be prompted with the following pop-up:

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 It is important that in this step, you select the Only delete this list and keep contacts associated with this list option. This will prevent any contact upload overages when we create a new list with the contacts you exported in step 2. 

 

Create a new list

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Back on the main contact list page, navigate to the create dropdown and select New List. You will then be prompted to name your new list. You can name it the same as your previous list or you can name it differently. It is important in this step to not add your contacts to the list just yet.

Edit your automation to send to the newly created list

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Navigate back to your disabled automation and scroll down to where you designate what list the automation sends to. Using the dropdown that has all of your lists and segments, select the list we just created with 0 contacts, as this will now be the list the automation will be set to send to. This is also the step where you can make any revisions to your overall automation such as content and subject lines before it goes live.

 

Set your Automation live

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Once you have edited your automation to send to the new list, set your automation back to live by going to the automation options dropdown and selecting set live. This will then set the automation to start sending to any new contacts added to our new list. You will want to make sure that the automation is set to live before you add any contacts to the list.

 

Upload the CSV file with the contacts into that list

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Finally, navigate one final time back to the contacts page and click into our newly created list with 0 contacts that is now tied to our live automation. You will see an upload CSV button within there that will allow you to upload the contacts we exported in step 2. Since this would be the first time these contacts are added to your designated list, the automation will trigger as expected to all of the recipients in this list. 

 

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