Issue
This article explains the steps required to regain access to your Twilio SendGrid Direct account when you are locked out due to Two Factor Authentication (2FA).
Note! If you are unable to sign in to a Twilio SendGrid Unified* account with Two-Factor Authentication (2FA) enabled please follow these steps. Unified Login simplifies user experience by enabling Twilio users to utilize their Twilio email, password, and authentication settings across various products, including SendGrid. Unified log in to SendGrid account will be through this link. And from there users will use the product switcher in order to access SendGrid.
Product
Twilio SendGrid Email "Non-Unified accounts".
Cause
If you are unable to receive 2FA codes, or if you want to change the phone number used for two-factor authentication (the number is no longer active or belonged to a former employee), please check the steps below.
Resolution
If you’re not receiving the code via SMS message (or phone call), please check the following items:
- Note that VOIP/Landline numbers are NOT supported.
- Check that you don’t have any phone numbers blocked or with “Do not Disturb” activated.
- Check that your device is powered on and within cellphone coverage.
- Confirm that you’re receiving SMS from other services or friends.
If you are getting this error message "Sorry, we were unable to send SMS at this Time" please submit a ticket through Twilio SendGrid Support to have your number safe listed.
If you know your 2FA phone number but no longer have access to it, check if the Auth Type is set to "App". If so, confirm that you have access to the email address used to register your 2FA phone number and:
- Submit a phone number change request through Twilio Authy Support.
If you are unsure of your 2FA phone number or the owner of the 2FA phone number is no longer with your organization submit a ticket through Twilio SendGrid Support and provide the following information:
-
- The SendGrid Username that is not receiving a 2FA code.
- The 2FA phone number if known.
- If you have valid API keys and can currently send email through your account.
- If you have access to the phone number on file for your account.
Twilio SendGrid Support will respond to your ticket with the steps required in order to reset your 2FA phone number.
Additional Information
Check more details about 2FA clicking on Two-Factor Authentication.