'Last name' field grayed out upon Google SSO sign-up

Issue

The "Last name" option is grayed out in the "Tell Us About Yourself" section, for newly signed up SendGrid accounts via Google SSO, and it cannot be edited. 

 

Product

New Unified Twilio SendGrid accounts signing up with Google SSO.

Cause

The issue arises because your Google profile, used during the sign-up process, does not contain a last name. Since our system automatically retrieves the first and last names based on the information available in your Google personal profile, these fields cannot be manually edited, preventing you from continuing with the account set up process. 

 

Resolution

Please access your Google account at Basic Info and complete your personal information. SendGrid will pick it up automatically once updated, so the next time you try to log in to SendGrid from the Twilio Unified Console, you will be able to access your SendGrid account.

The following are the steps to update the information in your Google account:

 

 
 

 

After completing all the steps, please clear the cache and cookies for all time and login at twilio.com using your email address and password. Our system should retrieve the updated information then, and you will be able to see the first name and last name, according to the personal details entered in your Google account



After clicking the "Get Started" button, you will be directed to the SendGrid interface. However, if you see this error instead:

 

 
Please reach out to SendGrid Support, as it is possible that your account has been automatically suspended, and it needs to be reviewed by our Compliance Team. 

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