Google SSO Sign-Up Process Stalled Due to Missing Last Name Data

Issue

Last name option is grayed out in the account set up for newly signed up SendGrid accounts via Google SSO. 

 

Product

New Unified Twilio SendGrid accounts signing up via Google SSO.

 

Cause

The issue arises because your Google profile, used during the sign-up process, does not contain a last name. Consequently, the last name field is grayed out during account setup in the unified_acct system when signing up via Google SSO. This prevents customers from completing their account setup.

The system automatically retrieves the first and last names based on the information available in your Google personal profile.

 

Resolution

Please access your Google account at Basic Info and complete your personal information. SendGrid will pick it up automatically once updated, so the next time you try to log in to SendGrid from the Twilio Unified Console, you will be able to access your SendGrid account. Step by step:

 

 

 
 

 

After following all the steps, please clear the cache and cookies for all time and login to your SendGrid account again. So that this new changes will be configured on SendGrid account setup page. After that, user would be able to see the first name and last name as per personal details mentioned in Gmail



Once you have followed these steps, users will be able to log in to the SendGrid account. If users see the below-mentioned error after following all the steps:

 

 
User needs to reach out to SendGrid Support and the account will be reviewed by our Compliance Team. 

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