Issue
If you see the error message below it means you may have accidentally locked yourself out of your account.
Product
Twilio SendGrid (Email)
Cause
IP Access Management is a security feature that allows you to control who can access your SendGrid account based on the IP address. After you allow an IP address, you can only access the SendGrid UI, API, and SMTP relay if you are connecting from an allowed IP address. Any access attempts from other IPs will be blocked. This is a powerful security tool that you can use to help prevent malicious activity on your account. The error above might appear if you’re using a non-static IP address to access SendGrid, if you're connecting through a VPN or a business internet service, and your current IP address isn’t included in your allowed list.
Resolution
If you have accidentally locked yourself out of your account, and yours is a teammate account, you can reach out to the primary administrator or another teammate, so they can add your IP to the Allow list.
If you are the primary administrator, or do not know who else might have access to your account, we’re here to help you regain access! We’ll need thorough proof of your identity and ownership of the account for security reasons, as we take account security very seriously. Please click here to contact SendGrid Support for assistance.
Additional Information
Reseller accounts, that log to SendGrid directly through the Reseller Marketplace, might see a "Single Sign-On failed" error instead. If so, please take note of the Request ID and contact SendGrid support for assistance.