Cannot invite teammate due to 'email already exists' error

Issue

When inviting a coworker to your SendGrid account through the teammates feature we have here, you might see the error "Email already exists" even if this is the first time you invite that person to your account. This article provides solutions to resolve this issue.

Product

Twilio SendGrid Email.

 

Cause

This error occurs because the email address you are trying to invite is already linked to a separate (different) SendGrid account.

 

Resolution

To resolve this issue, you can choose one of the following solutions:

1. The teammate-to-be can change the Email Address on their existing account

a) If the teammate-to-be has a SendGrid legacy account already associated with their email address, the following are the required steps:

    1. Log into Your SendGrid Account:
      • Navigate to the 

        SendGrid login page and enter the credentials to access your account (username and password). 

    2. Navigate to User Settings:
      • In the account settings menu, look for "User Settings" or "Account Details." This section allows you to manage your personal information, including your email address.



    3. Update Email Address:
  • Find the option to update your email address. This might be labeled as "Edit Email" or "Change Email."
  • Enter the new email address you wish to use for your account and Save.

b) If the teammate-to-be has a Twilio legacy or Twilio Unified account already associated with their email address, please follow these steps instead:

  1. Change the email address linked to the Twilio account:
  2. If the teammate-to-be doesn't remember the password of the Twilio account:

2. Modify the Email for Invitation

  1. Add a "+1" to the Email Address: When sending the invitation, modify the email address by adding a "+1" before the "@" symbol (e.g., example+1@example.com).
  2. Send the Invitation: Use the modified email address to send the invitation. This workaround allows the invitation to be sent without conflict.

    Note: Modifying the email for invitation might require assistance from your IT team, as some organizations do not permit the use of "+1" addresses for email aliases.

3. Creating an Email Alias

Another option is to create an email alias for the teammate’s email address. This method might also necessitate involvement from the IT team on the teammate's side, but is often more feasible than using "+1" addresses. An email alias allows the same inbox to receive emails sent to different addresses.

Additional Information 

For more information on resetting passwords for Twilio SendGrid accounts, please refer to this article.

 

 
Have more questions? Submit a request