Understanding the "Maximum Credits Exceeded" error

Issue

Customers may encounter a "Maximum credits exceeded" error when being on a paid plan for a long time, or after upgrading from the Email API Free edition to a paid version. 

 

Product

Twilio SendGrid (Email)

 

Cause

There are two possible scenarios when you can encounter this error, and each one has a different cause:

1. If you have been using your account for some time already:

a) Your account is under the Free Email API plan: These accounts have a daily 100-credit limit. 

b) A downgrade to a Free edition might have been processed: This could have happened by mistake or as a result of an account reactivation after a billing termination

c) Your account was created through a Reseller: Although these accounts allow for overages that are charged through the billing system of the reseller, these accounts have an artificial credit limit, that is 2.5x times the plan allotment. For example, if your reseller account is under the Email API Pro 100k plan, the credit limit is set to 250K. The reason for this specific policy is that after this point, paying for overages is more expensive than upgrading the plan to the next available option. 

 

2. If you recently upgraded from the Free edition to a Paid one: 

a) You upgraded the Marketing Campaigns plan instead of the Email API one: Credit limits are only applied to the Email API plan. 

b) You upgraded the Email API plan, but the plan has not been paid for yet: SendGrid is a service that is paid in advance, so if you upgrade, an invoice for the prorated charges will be generated. The credit limits are removed once the payment is confirmed. 

 

Resolution

To resolve the "Maximum credits exceeded" error, follow these steps:

Verify the Current Plan: If your account is under the Free Email API Plan, please wait until the next day (UTC time) for the credit count to reset. Otherwise, please make sure that your Email API plan is a paid one. You can do this, under Account Settings > Account Details > Your Products. 

Upgrade the Correct Plan: If the upgrade was applied to the Marketing Campaigns plan, downgrade it if not needed, and upgrade the Email API plan to the appropriate level. Detailed instructions can be found in the How to upgrade or change your SendGrid pricing plan guide.

Make sure that your payments are up-to-date: If you recently upgraded the Email API plan, make sure that the prorated charges have been paid for. 

Check your usage: You can use the Stats feature or the Event Webhook (if previously set up) to determine how many requests have been submitted during the month. Keep in mind that Requests = Processed + Dropped.

 

Additional Information 

If the issue persists after following these steps, or if no invoice was generated upon upgrade, please contact Twilio SendGrid support for further assistance.

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