Issue
Sending to Yahoo recipients often results in deferrals or bounces such as:
Email was deferred due to the following reason(s): [IPs were throttled by recipient server]
421 4.7.0 [TSS04] Messages from <IP> temporarily deferred due to unexpected volume or user complaints - 4.16.55.1; see https://postmaster.yahooinc.com/error-codes
Product
Twilio SendGrid (Email API and Marketing Campaigns)
Cause
There are two main causes for the issue:
- Not following good sending practices
- Yahoo's default hourly inbound rate is low
Resolution
About sending practices:
- Besides following our Deliverability Guide, Yahoo has their own requirements, described within their Sender Requirements & Recommendations
- Of particular importance for Yahoo, is setting up Reverse DNS (if your SendGrid account is under a plan that includes a dedicated IP) and ensuring that there is a valid DMARC record for the sending domain.
- To check if there has been any "user complaints" as stated in one of the most common error messages reported by Yahoo, we also recommend subscribing to their CFL (Complaint Feedback Loop) at https://senders.yahooinc.com/complaint-feedback-loop
About the Inbound Rate:
Unfortunately, there is no public documentation provided by Yahoo that explicitly states which is their Default Inbound Rate, but in practice, it appears to be around 100 emails per hour per IP. In consequence, the following are the strategies to deal with that:
- Segment your contact lists, so no more than 100 yahoo-related recipients (this includes email addresses at verizon.net, aol.com, aim.com, ymail.com, bellsouth.net, cox.net, frontier.com, netscape.net, rocketmail.com and rogers.com, among others) are included in any given sent.
- Schedule sends to those customers as not to send to more than 100 yahoo-related recipients per hour. (Ideally, the number should be about 50 emails per hour, in order to prevent cumulative deferrals).
- If possible, adding another IP to your account, with the corresponding rDNS will help, as that would allow you to send double the amount of emails per hour.
If you are sending emails using Shared IPs, we recommend scheduling your mail for off-peak times (for example, sending at 8:17 rather than 8:00 or 8:30).
Additional Information
- If you are sending using dedicated IPs and still see deferrals or bounces despite having followed our advice, please contact Yahoo support directly at https://senders.yahooinc.com/contact/#sender-support-request
- If you require further assistance, feel free to reach out to our Support team. We are available 24x7.