Activity feed can't export more than one million events

Issue

When exporting data from your Activity Feed, it is possible to face some issues if the amount of events to be exported contain more than one million of events. It seems important to understand that this is not always the reason behind an activity export issue, but if you know the amount of events could match the million data logs, then this is a great opportunity to review the amount of data being exported and follow our workarounds for this scenario.

 

Product

Twilio Email (SendGrid)

 

Cause

The main reason behind this issue is not pertaining to SendGrid, but moreover related to the fact that all CSV software (Excel, Google Sheets, etc...) can only have one million rows of data, so this is a technical limitation we can't circumvent, so this is a hard limitation. 

 

Resolution

The best way to overcome this issue is just to segment your data to lesser time ranges, so instead of selecting the same days or ranges, try to run your exports daily, or select different ranges until the limitation is not present!

 

Additional Information 

If you need data beyond 3 days, remember that we have available our EASE add-on for 7 and 30 days

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