How to Reset Two-Factor Authentication (2FA) for Non-Unified Twilio SendGrid Teammate Accounts

Issue

2FA is a mandatory requirement for every Twilio SendGrid account. When you create the teammate account, the email address submitted will receive an invitation email to activate the account. When the user clicks the link in the email, one of the first steps they must complete is to enroll in 2FA before they can access the SendGrid account.

Product

Email.

Cause

In the event a non-unified Twilio SendGrid Teammate account requires a Two-Factor Authentication (2FA) reset, please follow the step outlined below. If this step cannot be completed or are unsuccessful, please contact Support for further assistance.

Resolution

If you need to reset Two-Factor Authentication (2FA) for a non-unified teammate account, please use the following method:

1. Please visit the following link. From here, you would be able to request a phone number change for your teammate account. You must know the number, you don’t need to have the access to number.

Important: users must have an Auth ID set up as "app" to take advantage of the "Auth Phone Number Change Request" form. Otherwise the request will not reflect on your SendGrid account. You will follow these steps:

2. Set your existing phone number as Old Phone number.
3. Set your current phone number as New phone number.

Screenshot 2024-03-23 at 5.19.01 PM.png

4. Check your inbox/spam folders for a mail from noreply@authy.com and approve the phone change. This process can take between 2-4 business days. During this time, your account will be carefully validated to ensure it does not fall into malicious hands. You may be asked for additional information during this process, and all updates will be sent to the email address on file for your Authy account. 

Additional Information 

If you have a Twilio SendGrid Unified teammate account, it means your Sendgrid and Twilio credentials are linked. To manage your profile details and login credentials, go to the Twilio console. If you are unable to log in to your Unified teammate due to 2FA issues, please see our troubleshooting guide Unable to Sign In to a Twilio Account With Two-Factor Authentication (2FA) Enabled.

Have more questions? Submit a request