Issue
2FA is a mandatory requirement for every Twilio SendGrid account. When you create the teammate account, the email address submitted will receive an invitation email to activate the account. When the user clicks the link in the email, one of the first steps they must complete is to enroll in 2FA before they can access the SendGrid account.
Product
Email.
Cause
In the event a non-unified Twilio SendGrid Teammate account requires a Two-Factor Authentication (2FA) reset, please follow the step outlined below. If this step cannot be completed or are unsuccessful, please contact Support for further assistance.
Resolution
If you need to reset Two-Factor Authentication (2FA) for a non-unified teammate account, please use the following method:
Important: users must have an Auth ID set up as "app" to take advantage of the "Auth Phone Number Change Request" form. Otherwise the request will not reflect on your SendGrid account. You will follow these steps:
Additional Information
If you have a Twilio SendGrid Unified teammate account, it means your Sendgrid and Twilio credentials are linked. To manage your profile details and login credentials, go to the Twilio console. If you are unable to log in to your Unified teammate due to 2FA issues, please see our troubleshooting guide Unable to Sign In to a Twilio Account With Two-Factor Authentication (2FA) Enabled.