Issue
From time to time, some users may have issues trying to access their Twilio SendGrid account page, including SSL or Unreachable Page errors. This guide walks through common troubleshooting steps for account access issues.
Product
Twilio SendGrid (Email)
Cause
Possible causes include Browser issues, Network issues, Firewalls, Account suspension issues or using the incorrect login page.
Resolution
If yours is a SendGrid Legacy account (created before 2024)
- Verify there's only one (1) instance of the Twilio SendGrid account being accessed at a single time. Having multiple browsers logged into the same account can result in problems.
- Are you on a VPN? If so, try disconnecting, and see if that changes your results.
- Settings enabled or disabled in a particular web browser could cause issues accessing certain websites or captcha issues. To confirm if this is the issue, attempt to login to your SendGrid account using another web browser. We recommend using the Chrome or Safari.
- Try to access your SendGrid account, using an incognito or private browser window.
- Clear your browser cache and cookies. On Chrome, you can do this by accessing chrome://settings/clearBrowserData. Please note this may remove saved passwords, history, and more.
If your account was created through one of our Resellers
If your SendGrid account was created through a third party website such as Azure, Heroku, IBM, or other reseller partner service, you are not meant to log in through https://login.sendgrid.com but directly through the Marketplace of your reseller. We have some specific guides for that can help with reseller access and requests here:
- Single Sign On Failed
- Identifying your Subscription Id
- Login for SendGrid accounts created via Azure
If these articles don't help you regain access to your account, please download a HAR file of the login warning you see and provide that to SendGrid support in your support ticket.
If your account was created after March of 2024
This means that yours is most likely a Twilio Unified account. These accounts should log in at https://www.twilio.com/login using the corresponding email address.
For issues accessing the Twilio Console, you can follow the same troubleshooting steps provided for SendGrid Legacy accounts (the main difference is the login page), along with the steps described in this support article: Unable to Log in to my Twilio Account
Once in the Twilio Console, you'll need to use the product switcher to access the SendGrid instance. If you cannot access the SendGrid UI at this point:
- If you get stuck in the "Tell Us About Yourself" pop-up window, because your last name is less than two characters long: Please go back to the Twilio Console, click the icon at the top right corner and select User Settings. Once there, click the Edit button on the Personal Information section and edit your Last Name. After completing this step it is recommended to log out from the Twilio Console, and log back in, so the update can propagate to the SendGrid account.
- If you signed up using Google SSO and get stuck in the "Tell Us About Yourself" pop-up window, with the Last Name field grayed out, please follow the troubleshooting at 'Last name' field grayed out upon Google SSO sign-up
Additional Information
If you still have a different login issue, please take a look at the other possible troubleshooting articles we offer:
- Unable to login to Twilio SendGrid Direct Account due to 2FA
- Troubleshooting Unified Account creation issues
Still unable to access the SendGrid account?
If after following all possible troubleshooting you're still unable to access your Twilio SendGrid account, please contact our Support team with screenshots and additional logs to investigate further.